Sever down due to host suspension
Resolved
May 25, 2026 at 2:46pm UTC
The issue is resolved, we are monitoring the server and seeing if it has properly recovered
Affected services
Updated
May 25, 2026 at 6:51am UTC
We're in talks with the host, and working on a solution
Affected services
Updated
May 24, 2026 at 5:32pm UTC
The host has chosen to block the server again, and we've yet to receive a response from them in an earlier email.
Affected services
Updated
May 8, 2026 at 7:43pm UTC
The Issues are not resolved and we still have issues with our host, however we did somehow get back server access.
Affected services
Created
May 7, 2026 at 11:04pm UTC
We are actively working out the details with the host or trying to get in to contact with them, however since they're are EU based (same as us) everyone is now asleep. We hope to bring services back soon.
Affected services